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Altera Corporation 
About this Tutorial
This tutorial provides comprehensive information that will help you 
understand how to create an Altera® FPGA design and run it on your 
development board.

How to Contact 
Altera

For the most up-to-date information about Altera products, refer to the 
following table.

Typographic 
Conventions

This document uses the typographic conventions shown below.

Information Type Contact (1)

Technical support www.altera.com/mysupport/ 

Technical training www.altera.com/training/
custrain@altera.com

Product literature www.altera.com/literature/ 

Altera literature services literature@altera.com 

FTP site ftp.altera.com 

Note to table:
(1) You can also contact your local Altera sales office or sales representative. 

Visual Cue Meaning

Bold Type with Initial 
Capital Letters 

Command names, dialog box titles, checkbox options, and dialog box options are 
shown in bold, initial capital letters. Example: Save As dialog box. 

bold type External timing parameters, directory names, project names, disk drive names, 
filenames, filename extensions, and software utility names are shown in bold 
type. Examples: fMAX, \qdesigns directory, d: drive, chiptrip.gdf file.

Italic Type with Initial Capital 
Letters 

Document titles are shown in italic type with initial capital letters. Example: AN 
75: High-Speed Board Design.

Italic type Internal timing parameters and variables are shown in italic type. 
Examples: tPIA, n + 1.

Variable names are enclosed in angle brackets (< >) and shown in italic type. 
Example: <file name>, <project name>.pof file. 
 v
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Typographic Conventions My First FPGA Design Tutorial
Initial Capital Letters Keyboard keys and menu names are shown with initial capital letters. Examples: 
Delete key, the Options menu. 

“Subheading Title” References to sections within a document and titles of on-line help topics are 
shown in quotation marks. Example: “Typographic Conventions.”

Courier type Signal and port names are shown in lowercase Courier type. Examples: data1, 
tdi, input. Active-low signals are denoted by suffix n, e.g., resetn.

Anything that must be typed exactly as it appears is shown in Courier type. For 
example: c:\qdesigns\tutorial\chiptrip.gdf. Also, sections of an 
actual file, such as a Report File, references to parts of files (e.g., the AHDL 
keyword SUBDESIGN), as well as logic function names (e.g., TRI) are shown in 
Courier. 

1., 2., 3., and
a., b., c., etc.

Numbered steps are used in a list of items when the sequence of the items is 
important, such as the steps listed in a procedure. 

■ ● • Bullets are used in a list of items when the sequence of the items is not important. 

v The checkmark indicates a procedure that consists of one step only.

1 The hand points to information that requires special attention. 

c
The caution indicates required information that needs special consideration and 
understanding and should be read prior to starting or continuing with the 
procedure or process.

w The warning indicates information that should be read prior to starting or 
continuing the procedure or processes

r The angled arrow indicates you should press the Enter key.

f The feet direct you to more information on a particular topic. 

Visual Cue Meaning
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1. My First FPGA Design
Introduction Welcome to Altera and the world of programmable logic! This tutorial 
will teach you how to create a simple FPGA design and run it on your 
development board. The tutorial takes less than an hour to complete. The 
following sections provide a quick overview of the design flow, explain 
what you need to get started, and describe what you will learn.

Design Flow

The standard FPGA design flow starts with design entry using 
schematics or a hardware description language (HDL), such as 
Verilog HDL or VHDL. In this step, you create the digital circuit that is 
implemented inside the FPGA. The flow then proceeds through 
compilation, simulation, and programming and verification in the FPGA 
hardware (see Figure 1–1). 

Figure 1–1. Design Flow

This tutorial guides you through all of the steps except for simulation. 
Although it is not covered in this document, simulation is very important 
to learn, and there are entire applications devoted to simulating hardware 
designs. There are two types of simulation, RTL and timing. RTL (or 
functional) simulation allows you to verify that your code is 
manipulating the inputs and outputs appropriately. Timing (or post 
place-and-route) simulation verifies that the design meets timing and 
functions appropriately in the device. 

1 See “Next Steps” on page 1–43 for links to further information 
about simulation.

Design Compile Simulate Program Hardware
Verify
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Introduction
Before You Begin

This tutorial assumes the following prerequisites:

■ You generally know what an FPGA is. This tutorial does not explain 
the basic concepts of programmable logic.

■ You are somewhat familiar with digital circuit design and electronic 
design automation (EDA) tools.

■ You have installed the Altera® Quartus® II software on your 
computer. If you do not have the Quartus II software, you can 
download it from the Altera web site at www.altera.com/download.

■ You have an Altera Cyclone® III Starter Board (or equivalent) on 
which you will test your project. Using a development board helps 
you to verify whether your design is really working.

■ You have gone through the quick start guide and/or the getting 
started user guide for your development kit. These documents 
ensure that you have:

● Installed the required software.

● Determined that the development board functions properly and 
is connected to your computer.

● Installed the USB-Blaster™ driver, which allows you to program 
the FPGA on the development board with your own design.

What You Will Learn

In this tutorial, you will perform the following tasks:

■ Create a design that causes LEDs on the development board to blink at a 
speed that is controlled by an input button—This design is easy to create 
and gives you visual feedback that the design works. Of course, you 
can use your Cyclone III board to run other designs as well. For the 
LED design, you will write Verilog HDL code for a simple 32-bit 
counter, add a phase-locked loop (PLL) megafunction as the clock 
source, and add a 2-input multiplexer megafunction. When the 
design is running on the board, you can press an input switch to 
multiplex the counter bits that drive 4 output LEDs.
1–2  Altera Corporation
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My First FPGA Design
■ Become familiar with Quartus II design tools—This tutorial will not 
make you an expert, but at the end, you will understand basic 
concepts about Quartus II projects, such as entering a design using a 
schematic editor and HDL, compiling your design, and 
downloading it into the FPGA on your development board.

■ Develop a foundation to learn more about FPGAs—For example, you can 
create and download digital signal processing (DSP) functions onto 
a single chip, or build a multi-processor system, or create anything 
else you can imagine all on the same chip. You don’t have to scour 
data books to find the perfect logic device or create your own ASIC. 
All you need is your computer, your imagination, and the Cyclone III 
Starter Board.

For information about Altera training classes (both on-line and in 
person), go to the Altera web site at mysupport.altera.com/etraining/ or 
contact your local Altera sales representative.

Get Started You begin this tutorial by creating a new Quartus II project. A project is a 
set of files that maintain information about your FPGA design. The 
Quartus II Settings File (.qsf) and Quartus II Project File (.qpf) files are the 
primary files in a Quartus II project. To compile a design or make pin 
assignments, you must first create a project.

1. In the Quartus II software, select File > New Project Wizard. The 
Introduction page opens. See Figure 1–2.
Altera Corporation  1–3
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Get Started
Figure 1–2. New Project Wizard: Introduction

2. Click Next.

3. Enter the following information about your project:

a. What is the working directory for this project? Enter a 
directory in which you will store your Quartus II project files 
for this design, for example, c:\altera\my_first_fpga.

1 File names, project names, and directories in the Quartus II 
software cannot contain spaces.

b. What is the name of this project? Type my_first_fpga. 

c. What is the name of the top-level design entity for this 
project? Type my_first_fpga_top. See Figure 1–3. 
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Figure 1–3. Project Information

d. Click Finish.

1 The wizard has several other pages after this one; however, 
for this tutorial you do not need to make changes to these 
pages. For more information on the options available in 
these pages, refer to the Quartus II Handbook.

4. When prompted, choose Yes to create the my_first_fpga project 
directory.

Congratulations! You just created your first Quartus II FPGA project. See 
Figure 1–4. 
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Design Entry
Figure 1–4. my_first_fpga Project

Design Entry In the design entry phase, you use RTL or schematic entry to create the 
logic to be implemented in the device. You also make pin assignments, 
including pin placement information, and timing constraints that might 
be necessary for building a functioning design.

In the design entry step you create a schematic or Block Design File (.bdf) 
that is the top-level design. You will add library of parameterized 
modules (LPM) functions and use Verilog HDL code to add a logic block. 
When creating your own designs, you can choose any of these methods 
or a combination of them.

1. Choose File > New > Block Diagram/Schematic File (see 
Figure 1–5) to create a new file, Block1.bdf, which you will save as 
the top-level design.
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Figure 1–5. New BDF

2. Choose File > Save As and enter the following information (see 
Figure 1–6).

● File name: my_first_fpga_top
● Save as type: Block Diagram/Schematic File (*.bdf)
Altera Corporation  1–7
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Design Entry
Figure 1–6. Saving the BDF

3. Click Save. The new design file appears in the Block Editor (see 
Figure 1–7). 
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Figure 1–7. Blank BDF

4. Add HDL code to the blank block diagram by choosing File > New 
> Verilog HDL File (see Figure 1–8).
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Design Entry
Figure 1–8. New Verilog HDL File

5. Click OK to create a new file Verilog1.v, which you will save as 
simple_counter.v.

6. Select File > Save As and enter the following information (see 
Figure 1–9).

● File name: simple_counter.v 
● Save as type: Verilog HDL File (*.v, *.vlg, *.verilog)
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Figure 1–9. Saving the Verilog HDL File

The resulting empty file is ready for you to enter the Verilog HDL 
code.

7. Type the following Verilog HDL code into the blank 
simple_counter.v file (see Figure 1–10). 

1 If you are reading this document as a PDF file, you can copy 
the code from the PDF and paste it into the blank file.

// This is an example of a simple 32 bit up-counter called simple_counter.v
// It has a single clock input and a 32-bit output port
module simple_counter (input clock , output reg [31:0] counter_out); 
always @ (posedge clock)// on positive clock edge
begin 
 counter_out <= #1 counter_out + 1;// increment counter
end 
endmodule// end of module counter
Altera Corporation  1–11
My First FPGA Design Tutorial



Design Entry
Figure 1–10. simple_counter.v

8. Save the file by choosing File > Save, pressing Ctrl + s, or by 
clicking the floppy disk icon.

9. Choose File > Create/Update > Create Symbol Files for Current 
Update to convert the simple_counter.v file to a Symbol File (.sym). 
You use this Symbol File to add the HDL code to your BDF 
schematic.

The Quartus II software creates a Symbol File and displays a message 
(see Figure 1–11).

Figure 1–11. Symbol File Created

10. Click OK. 

11. To add the simple_counter.v symbol to the top-level design, click 
the my_first_fpga_top.bdf tab.
1–12  Altera Corporation
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12. Choose Edit > Insert Symbol.

13. Double-click the project directory, which shows the newly created 
simple_counter symbol, and select it by clicking it’s icon. 

1 You can also double-click in a blank area of the BDF to open 
the Symbol dialog box

Figure 1–12. Adding the Symbol to the BDF

14. Click OK.

15. Move the cursor to the BDF grid; the symbol image moves with the 
cursor. Click to place the simple_counter symbol onto the BDF. 
You can move the block after placing it by simply clicking and 
dragging it to where you want it and releasing the mouse button to 
place it. See Figure 1–13. 
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Design Entry
Figure 1–13. Placing the Symbol

16. Press the Esc key or click an empty place on the schematic grid to 
cancel placing further instances of this symbol. 

1 Save your project regularly.

Add a PLL Megafunction

Megafunctions, such as the ones available in the LPM, are pre-designed 
modules that you can use in FPGA designs. These Altera-provided 
megafunctions are optimized for speed, area, and device family. You can 
increase efficiency by using a megafunction instead of writing the 
function yourself. Altera also provides more complex functions, called 
MegaCore® functions, which you can evaluate for free but require a 
license file for use in production designs.

This tutorial design uses a PLL clock source to drive a simple counter. To 
create the clock cource, you will add a pre-built LPM megafunction 
named ALTPLL. 

1. Choose Edit > Insert Symbol or click Add Symbol on the toolbar 
( ). 

2. Click Megawizard Plug-in Manager. The MegaWizard® Plug-In 
Manager appears (see Figure 1–14).
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Figure 1–14. MegaWizard Plug-In Manager

3. Click Next.

4. In MegaWizard Plug-In Manager [page 2a], specify the following 
selections (see Figure 1–15):

a. Choose I/O > ALTPLL. 

b. Under Which device family will you be using?, choose 
Cyclone III.

c. Under Which type of output file do you want to create?, 
choose Verilog HDL. 

d. Under What name do you want for the output file?, type pll 
at the end of the already created directory name. 

e. Click Next.
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Figure 1–15. MegaWizard Plug-In Manager [page 2a] Selections

5. In the MegaWizard Plug-In Manager [page 3 of 12] window, make 
the following selections (see Figure 1–16):

a. Confirm that General > Which device family will you be 
using? is Cyclone III. 

b. Under Which device speed grade will you be using?, type 8. 

c. Under What is the frequency of the inclock0 input?, type 50.

d. Ensure that the units are MHz (default).

e. Click Next.
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Figure 1–16. MegaWizard Plug-In Manager [page 3 of 12] Selections

6. Turn off all options on MegaWizard page 4. As you turn them off, 
pins disappear from the PLL block’s graphical preview. See 
Figure 1–17.
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Figure 1–17. MegaWizard Plug-In Manager [page 4 of 12] Selections

7. Click Next.

8. At the top of the wizard, click the tab 2. Output Clocks to jump to 
page 7.

9. Under Clock division factor, use the up/down arrows or enter 10. 
See Figure 1–18.
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Figure 1–18. MegaWizard Plug-In Manager [page 7 of 12] Selections

10. Click Finish.

11. The wizard displays a summary of the files it creates (see 
Figure 1–19). Click Finish again. 
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Figure 1–19. Wizard-Created Files

The Symbol window opens, showing the newly created PLL 
megafunction. See Figure 1–20.
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Figure 1–20. pll Symbol

12. Click OK and place the pll symbol onto the BDF to the left of the 
simple_counter symbol. See Figure 1–21.

Figure 1–21. Place the pll Symbol
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13. Move the mouse so that the cursor (also called the selection tool) is 
over the pll symbol’s c0 ouput pin. The orthogonal node tool 
(cross-hair) icon appears.

14.  Click and drag a bus line from the c0 output to the 
simple_counter clock input. This action ties the pll output to 
the simple_counter input (see Figure 1–22).

Figure 1–22. Draw a Bus Line from pll to simple_counter

15. Add an input pin and an output bus with the following steps:

a. Choose Edit > Insert Symbol. 

b. Under Libraries, double-click quartus/libraries/ directory > 
primitives > pin > input.

c. Click OK. See Figure 1–23.

1 If you need more room to place symbols, you can use the 
vertical and horizontal scroll bars at the edges of the BDF 
window to view more drawing space.
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Figure 1–23. Input Pin Symbol

d. Place the new pin onto the BDF so that it is touching the input 
to the pll symbol. 

e. Use the mouse to click and drag the new input pin to the left; 
notice that the ports remain connected as shown in Figure 1–24.

Figure 1–24. Connecting Input Pin

f. Change the pin name by double-clicking pin_name and typing 
CLOCK_50 (see Figure 1–25). This pin corresponds to the 
development board’s CLOCK_50 input pin, which is connected 
to the Cyclone III FPGA on the board.
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Design Entry
Figure 1–25. Change Input Pin Name

g. Using the Orthoganal Bus tool, draw a bus line from the 
simple_counter output port. 

h. Right-click the new output bus line and choose Properties. 

i. Type counter[31..0] as the bus name (see Figure 1–26). The 
notation [X..Y] is the Quartus II method for specifying the bus 
width in BDF schematics, where X is the most significant bit 
(MSB) and Y is the least significant bit (LSB).

Figure 1–26. Change Output Bus Name

j. Click OK. Figure 1–27 shows the BDF.
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Figure 1–27. BDF

Add a Multiplexer

This design uses a multiplexer to route the simple_counter output to 
the LED pins on the development board. You will use the MegaWizard 
Plug-In Manager to add the multiplexer, lpm_mux. The design 
multiplexes two variations of the counter bus to four LEDs on the 
development board. 

1. Choose Edit > Insert Symbol. 

2. Click Megawizard Plug-in Manager. 

3. Click Next.

4. Choose Installed Plug-Ins > Gates > LPM_MUX. 

5. Choose Cyclone III as the device family and name the output file 
counter_bus_mux (see Figure 1–28).

6. Click Next.
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Design Entry
Figure 1–28. Selecing lpm_mux

7. Under How many ‘data’ inputs do you want?, select 2 inputs 
(default).

8. Under How ‘wide’ should the data input and result output be?, 
select 4 (see Figure 1–29).
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Figure 1–29. lpm_mux Settings

9. Click Next.

10. Click Finish. The Symbol window appears (see Figure 1–30).
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Figure 1–30. lpm_mux Symbol

11. Click OK.

12. Place the counter_bus_mux symbol below the existing symbols 
on the BDF. See Figure 1–31.
1–28  Altera Corporation
My First FPGA Design Tutorial



My First FPGA Design
Figure 1–31. Place the lpm_mux Symbol

13. Add input buses and output pins to the counter_bus_mux symbol 
as follows: 

a. Using the Orthoganal Bus tool, draw bus lines from the 
data1x[3..0] and data0x[3..0] input ports. 

b. Draw a bus line from the result[3..0] output port.

c. Right-click the bus line connected to data1x[3..0] and 
choose Properties. 

d. Name the bus counter[26..23], which selects only those 
counter output bits for this input bus.

e. Click OK.

f. Right-click the bus line connected to data0x[3..0] and 
choose Properties. 
Altera Corporation  1–29
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g. Name the bus counter[24..21], which selects only those 
counter output bits for this input bus.

h. Click OK. Figure 1–32 shows the renamed buses.

Figure 1–32. Renamed counter_bus_mux Bus Lines

14. Choose Edit > Insert Symbol. 

15. Under Libraries, double-click quartus/libraries/ directory > 
primitives > pin > output (see Figure 1–33).

Figure 1–33. Choose an Output Pin

16. Click OK.

17. Place this output pin so that it connects to the counter_bus_mux 
result[3..0] bus output line.

18. Rename the output pin as LED[3..0] as described in steps 13 c and 
d. With this name, it corresponds to the output pins LED0 through 
LED3 on the board, which are connected to the Cyclone III FPGA 
(see Figure 1–34).
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Figure 1–34. Rename the Output Pin

19. Attach an input pin to the multiplexer select line using an input pin:

a. Choose Edit > Insert Symbol. 

b. Under Libraries, double-click quartus/libraries/ directory > 
primitives > pin > input.

c. Click OK.

20. Place this input pin below counter_bus_mux. 

21. Connect the input pin to the counter_bus_mux sel pin.

22. Rename the input pin as KEY[0] (see Figure 1–35).
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Figure 1–35. Adding the KEY[0] Input Pin

You have finished adding symbols to your design.

1 You can add notes or information to the project as text using the 
the Text tool on the toolbar (indicated with the A symbol). For 
example, you can add the label “OFF = SLOW, ON = FAST” to 
the KEY[0] input pin and add a project description, such as 
“My First FPGA Project.”

Assign Cyclone III Device and Pins

In this section, you will assign a specific Cyclone III FPGA device to the 
design and make pin assignments. To assign the device, perform the 
following steps.

1. Choose Assignments > Device. 

2. Under Family, choose Cyclone III. 

3. Under Available devices, choose EP3C25F324C8 as the device. See 
Figure 1–36.
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Figure 1–36. Specify the Cyclone III Device

4. Click OK. 

5. Choose Processing > Start > Start Analysis & Elaboration in 
preparation for assigning pin locations.

6. Click OK in the message window that appears after analysis and 
elaboration completes.

To make pin assignments that correlate to the KEY[0] and CLOCK_50 
input pins and LED[3..0] output pin, perform the following steps.

1. Choose Assignments > Pins, which opens the Pin Planner, a 
spreadsheet-like table of specific pin assignments. The Pin Planner 
shows the design’s six pins. See Figure 1–37.
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Figure 1–37. Pin Planner

2. In the Location column next to each of the six node names, add the 
FineLine® BGA (FBGA) coordinates (pin numbers) as shown in 
Table 1–1. 

Table 1–1. Location Pin Settings

Row Node Name Location

1 KEY[0] F1

2 CLOCK_50 V9

3 LED[0] P13

4 LED[1] P12

5 LED[2] N12

6 LED[3] N9
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Double-click in the Location column for any of the six pins to open a 
drop-down list. You can select the pin from this list. Alternatively, you can 
type the location. For example, if you type F1 and press the Enter key, the 
Quartus II software fills in the correct PIN_F1 location name for you. The 
software also keeps track of corresponding FPGA data such as the I/O 
bank and Vref group. Each bank has a distinct color, which corresponds 
to the top-view wire bond drawing in the upper right window. See 
Figure 1–38.

1 As a shortcut, drag and drop the pin from the FPGA pin diagram 
into the pin table. Make sure that you select the correct pins 
when using this method.

For Cyclone III devices, unused I/O pins default to tri-stated inputs. You 
can change this setting using the Unused Pins tab in the Device and Pin 
Options dialog box. Refer to Quartus II Help for more information about 
this option and how to use it.

1 Altera provides board reference manuals and schematics for all 
development boards. These documents provide complete 
information about the pinouts for the devices on the boards.
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Figure 1–38. Completed Pin Planning

You are finished creating your Quartus II design!

Compile Your 
Project

After creating your design you must compile it. Compilation converts the 
design into a bitstream that can be downloaded into the FPGA. The most 
important output of compilation is an SRAM Object File (.sof), which you 
use to program the device. The software also generates other report files 
that provide information about your code as is compiles. 

1 If you want to store SOFs in memory devices (such as flash or 
EEPROMs), you must first convert the SOF to a file type 
specifically for the targeted memory device. 

Now that you have created a complete Quartus II project and entered all 
assignments, you can compile the design. 
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v In the Processing menu, choose Start Compilation or click the Play 

button on the toolbar ( ).

1 If you are asked to save changes to your BDF, click Yes. 

While compiling your design, the Quartus II software provides useful 
information about the compilation (see Figure 1–39). 

Figure 1–39. Compilation Messages

When compilation is complete, the Quartus II software displays a 
message. Click OK to close the message box.
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1 The Quartus II Messages window displays many messages 
during compilation. In this exercise, you did not create any 
timing constraints. Therefore, the Quartus II software issues two 
critical warnings:

Critical Warning: SDC file not found: ‘my_first_fpga_top.sdc’ 
Critical Warning: Timing requirements not met

The second warning is displayed because no timing 
requirements were made, therefore, they could not be met. For 
this tutorial project, you can ignore these warnings. However, 
setting timing requirements is a critical part of creating 
successful designs. For more information on setting timing 
requirements, refer to Quartus II Help and/or the Altera 
etraining courses mentioned in “Next Steps” on page 1–43.

The software provides the compilation results in the Compilation Report 
tab as shown in Figure 1–40.

Figure 1–40. Compilation Report
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My First FPGA Design
Program the 
Device

After compiling and verifying your design you are ready to program the 
Cyclone III FPGA on the development board. You download the SOF you 
just created into the FPGA using the USB-Blaster circuitry on the board. 

Set up your hardware for programming using the following steps:

1. Connect the power supply cable to your board and to a power 
outlet.  

2. Connect the USB cable to your host computer and the board. 

1 Refer to the getting started user guide for detailed 
instructions on how to connect the cables.

3. Turn the board on using the on/off switch (SW1).

Program the FPGA using the following steps.

1. Choose Tools > Programmer. The Programmer window opens. See 
Figure 1–41.
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Program the Device
Figure 1–41. Programmer Window

2. Click Hardware Setup. 

3. If it is not already turned on, turn on the USB-Blaster [USB-0] 
option under Currently selected hardware. See Figure 1–42.
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My First FPGA Design
Figure 1–42. Hardware Settings

4. Click Close. 

5. Click Add File.

6. Select the my_first_fpga_top.sof file from the project directory (see 
Figure 1–43).

Figure 1–43. Add Programming File

7. Click Open.
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Program the Device
8. Turn on the Program Configure option that corresponds to the 
my_first_fpga_top.sof file. 

9. Click Start. The file downloads to the development board. 

The progress bar shows the download status; the status is 100% 
when downloading completes. See Figure 1–44.

Figure 1–44. Downloading Complete

Congratulations, you have created, compiled, and programmed your first 
FPGA design! The compiled SRAM Object File (.sof) is loaded onto the 
Cyclone III FPGA on the development board and the design should be 
running.
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My First FPGA Design
Verify in 
Hardware

When you verify the design in hardware, you observe the runtime 
behavior of the FPGA hardware design and ensure that it is functioning 
appropriately. 

Verify the design by performing the following steps:

1. Observe that the four development board LEDs appear to be 
advancing slowly in a binary count pattern, which is driven by the 
simple_counter bits [26..23]. 

1 The LEDs are active low, therefore, when counting begins 
all LEDs are turned on (the 0000 state).

2. Press and hold Button 1 on the development board and observe that 
the LEDs advance more quickly. Pressing this button causes the 
design to multiplex using the faster advancing part of the counter 
(bits [24..21]).

Next Steps Altera provides many tutorials and reference material that you can use to 
further your knowledge of FPGA design. The information on the 
following web pages will help you learn more about Altera tools and 
products.

■ www.altera.com/education/univ/unv-index.html
■ www.altera.com/education/univ/materials/manual/unv-lab-

manual.html
■ www.altera.com/literature/lit-qts.jsp
■ www.altera.com/end-markets/refdesigns/ref-index.jsp
■ www.altera.com/support/examples/exm-index.html
■ www.altera.com/corporate/contact/con-index.html
■ mysupport.altera.com/etraining/

The Altera etraining page provides tutorials for each of the steps covered 
in this document. Additionally, it provides simulation tutorials, such as:

■ Using the Quartus II Software: Simulation
■ Using the Quartus II Software: Timing Analysis
■ Constraining and Analyzing Timing for Source Synchronous 

Circuits with TimeQuest
■ Validating Performance with the TimeQuest Static Timing Analyzer
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